jQuery 2.0 Adeus ao OldIE

Estamos ansiosos para o lançamento do jQuery 2.0 em 2013, e com ele o fim do suporte para o Internet Explorer 6-8.

“jQuery was conceived specifically to address the differences in browsers, so we’re not going to abandon the essence of our philosophy and simply disregard the millions of active Internet users who (for whatever reasons) still use oldIE. Yet we also want to move ahead and take advantage of modern browsers, especially the growing mobile market.”

A versão 1.9 da biblioteca, que também será lançada no começo de 2013 será totalmente compatível com as versões anteriores do navegador, portanto, vai valer a pena oferecer as duas versões para os sites que precisam ainda dar suporte para IE6-8. O comunicado de imprensa do jQuery já disponibiliza até um exemplo de como fazer essa condição!

O que muda?

O jQuery vem sendo para os desenvolvedores front-end um canivete suiço de Javascript. Com a vinda do jQuery, nossa vida ficou mais fácil, em especial por ele ser em maior parte do tempo cross-browser. Ter uma versão que ofereça suporte todos os navegadores e outra que nos abre centenas de novas funcionalidades para os chamados browsers modernos será uma experiência fantástica.

Mas calma! Você precisa se lembrar que…

Só porque o jQuery 2.0 não dará suporte para os IEs velhos não significa que você também não dará.
Ao desenvolver um site, devemos tomar como base estatísticas do passado, o público-alvo, e fazer desse site um objeto de melhoria contínua, acompanhando sempre o feedback dos usuários através de análise.
Ir para o tudo-ou-nada quando se trata de suporte a navegadores antigos nem sempre é uma decisão sábia e no final pode custar caro!